The Poetry team is pleased to announce the immediate availability of Poetry 1.1.4.

This release is a bugfix release.

If you have a previous version of Poetry installed via the official installer, getting Poetry 1.1.4 is as easy as:

$ poetry self update

Features

  • Added installer.parallel boolean flag (defaults to true) configuration to enable/disable parallel execution of operations when using the new installer. (#3088)

Changes

  • When using system environments as an unprivileged user, user site and bin directories are created if they do not already exist. (#3107)

Fixes

  • Fixed editable installation of poetry projects when using system environments. (#3107)
  • Fixed locking of nested extra activations. If you were affected by this issue, you will need to regenerate the lock file using poetry lock --no-update. (#3229)
  • Fixed prioritisation of non-default custom package sources. (#3251)
  • Fixed detection of installed editable packages when non-poetry managed .pth file exists. (#3210)
  • Fixed scripts generated by editable builder to use valid import statements. (#3214)
  • Fixed recursion error when locked dependencies contain cyclic dependencies. (#3237)
  • Fixed propagation of editable flag for VCS dependencies. (#3264)
View Comments