The Poetry team is pleased to announce the immediate availability of Poetry 1.1.1.

This release is a bugfix release.

If you have a previous version of Poetry installed via the official installer, getting Poetry 1.1.1 is as easy as:

$ poetry self update

Features

  • Added --no-update option to lock command. (#3034)

Fixes

  • Fixed resolution of packages with missing required extras. (#3035)
  • Fixed export of requirements.txt dependencies to include development dependencies. (#3024)
  • Fixed incorrect selection of unsupported binary distribution formats when selecting a package artifact to install. (#3058)
  • Fixed incorrect use of system executable when building package distributions via build command. (#3056)
  • Fixed errors in init command when specifying --dependency in non-interactive mode when a pyproject.toml file already exists. (#3076)
  • Fixed incorrect selection of configured source url when a publish repository url configuration with the same name already exists. (#3047)
  • Fixed dependency resolution issues when the same package is specified in multiple dependency extras. (#3046)
View Comments