The Poetry team is pleased to announce the immediate availability of Poetry 1.0.6.

This release is a bugfix release with some small changes to make the upgrade to future releases easier.

If you have a previous version of Poetry installed via the official installer, getting Poetry 1.0.6 is as easy as:

$ poetry self update

Changes

  • The self update command has been updated in order to handle future releases of Poetry (#2429).

Fixes

  • Fixed an error were a new line was not written when displaying the virtual environment's path with env info (#2196).
  • Fixed a misleading error message when the packages property was empty (#2265).
  • Fixed shell detection by using environment variables (#2147).
  • Fixed the removal of VCS dependencies (#2239).
  • Fixed generated wheel ABI tags for Python 3.8 (#2121).
  • Fixed a regression when building stub-only packages (#2000).
  • Fixed errors when parsing PEP-440 constraints with whitespace (#2347).
  • Fixed PEP 508 representation of VCS dependencies (#2349).
  • Fixed errors when source distributions were read-only (#1140).
  • Fixed dependency resolution errors and inconsistencies with directory, file and VCS dependencies (#2398).
  • Fixed custom repositories information not being properly locked (#2484).
View Comments