The Poetry team is pleased to announce the immediate availability of Poetry 1.0.1.

This release is a bugfix release.

If you have a previous version of Poetry installed via the official installer, getting Poetry 1.0.1 is as easy as:

$ poetry self update

Fixes

  • Fixed an error in env use where the wrong Python executable was being used to check compatibility (#1736).
  • Fixed an error where VCS dependencies were not properly categorized as development dependencies (#1725).
  • Fixed an error where some shells would no longer be usable after using the shell command (#1673).
  • Fixed an error where explicitly included files where not included in wheel distributions (#1750).
  • Fixed an error where some Git dependencies url were not properly parsed (#1756).
  • Fixed an error in the env commands on Windows if the path to the executable contained a space (#1774).
  • Fixed several errors and UX issues caused by keyring on some systems (#1788).
  • Fixed errors when trying to detect installed packages (#1786).
  • Fixed an error when packaging projects where Python packages were not properly detected (#1592).
  • Fixed an error where local file dependencies were exported as editable when using the export command (#1840).
  • Fixed the way environment markers are propagated and evaluated when resolving dependencies (#1829, #1789).
  • Fixed an error in the PEP-508 compliant representation of directory and file dependencies (#1796).
  • Fixed an error where invalid virtual environments would be silently used. They will not be recreated and a warning will be displayed (#1797).
  • Fixed an error where dependencies were not properly detected when reading the setup.py file in some cases (#1764).
View Comments